Custom recorder error

Post Reply
Lei Lei
Posts: 83
Joined: Mon Jul 10, 2023 1:28 pm

Custom recorder error

Post by Lei Lei » Thu Apr 11, 2024 2:56 am

Dear STKOteam,

I used two beam elements and a zerolengthsection element to simulate a beam with a gap in its middle. Just like figure1.

All the elements are assigned with a fiber section. I use the element recorder to output the elements' local force.

However, the beam on the gap's left can output successfully while the right beam can't.

Just like figure2, 3, and 4. The gap is element 35. I selected an element output for the left (element 19)and right(element 16) beams respectively.

The weird thing is that the right beam can output Stress-Stain properly.

Looking forward to your reply!
6d3e31de70a99ef25c1ca716000d23d.png
Figure1
6d3e31de70a99ef25c1ca716000d23d.png (44.55 KiB) Viewed 1022 times
0577469eed08d9f8ddebf2bbd344607.png
Figure2
0577469eed08d9f8ddebf2bbd344607.png (12.77 KiB) Viewed 1022 times
dcb72c27a5c4545015af7579677eeac.png
Figure3
dcb72c27a5c4545015af7579677eeac.png (20.68 KiB) Viewed 1022 times
db02cfeccbb7d3afb27be2e40bee2fc.png
Figure4
db02cfeccbb7d3afb27be2e40bee2fc.png (40.84 KiB) Viewed 1022 times

kesavapraba
Posts: 318
Joined: Sat Mar 28, 2020 2:25 pm

Re: Custom recorder error

Post by kesavapraba » Mon Apr 15, 2024 1:54 pm

Hi, I can only partially understand your issue since no details are there about the type of element etc.! Can you please send me the model?
:: With best wishes ::
Prabakaran Kesavan

Lei Lei
Posts: 83
Joined: Mon Jul 10, 2023 1:28 pm

Re: Custom recorder error

Post by Lei Lei » Tue Apr 16, 2024 2:09 pm

Dear STKOteam,
Lei Lei wrote:
Thu Apr 11, 2024 2:56 am
I used two beam elements and a zerolengthsection element to simulate a beam with a gap in its middle. Just like figure1.

All the elements are assigned with a fiber section. I use the element recorder to output the elements' local force.
The model described is shown below:
fea96232b54807edd0bbc0a581a3923.png
model description
fea96232b54807edd0bbc0a581a3923.png (53.19 KiB) Viewed 977 times
The problem is that I can output the local force of elements from the left curvilinear beam with a customer recorder script while the right beam just have the first column for time step.

However, for the stress-strain data of the beam's fiber sections, I can successfully output it for both cuvilinear beam.

My recorder scrip is as below, in which the element 19 is on the left beam while the element 16 is on the right.
26066a3ade5d5c445933814288e9189.png
recorder script
26066a3ade5d5c445933814288e9189.png (20.38 KiB) Viewed 977 times
Looking forward to your reply!

STKO Team
Posts: 2301
Joined: Tue Oct 29, 2019 8:45 am

Re: Custom recorder error

Post by STKO Team » Thu May 09, 2024 12:25 pm

please share your script/file

Lei Lei
Posts: 83
Joined: Mon Jul 10, 2023 1:28 pm

Re: Custom recorder error

Post by Lei Lei » Thu May 09, 2024 1:30 pm

Hi,

Here, I provide a similar simple case and the recorder scrips are in the 'custom output' command.

Looking forward to your reply!
Last edited by Lei Lei on Sat May 11, 2024 4:42 am, edited 1 time in total.

STKO Team
Posts: 2301
Joined: Tue Oct 29, 2019 8:45 am

Re: Custom recorder error

Post by STKO Team » Fri May 10, 2024 4:03 pm

Look at the end of the line where you define the recorder that is not working...
You are not using a regular semicolon! you are using a special character that is not recognized by tcl

Lei Lei
Posts: 83
Joined: Mon Jul 10, 2023 1:28 pm

Re: Custom recorder error

Post by Lei Lei » Sat May 11, 2024 4:50 am

OMG, what a careless mistake.!

Thank you for your kindness and attentiveness~

Best wishes~

STKO Team
Posts: 2301
Joined: Tue Oct 29, 2019 8:45 am

Re: Custom recorder error

Post by STKO Team » Mon May 13, 2024 8:18 am

You're welcome

Post Reply