Error During Analysis

Post Reply
nisaralikhan
Posts: 7
Joined: Fri Sep 25, 2020 9:51 am

Error During Analysis

Post by nisaralikhan » Sat Dec 04, 2021 2:50 pm

Dear STKO Team,
I have built the RC portal frame, as per my understanding, I defined everything correctly. But during analysis, I get an error which states that "forceBeamColumn could not invert flexibility" the detailed error screenshot is attached. I am also attaching the full model in a Zip folder (20211204_Bare Frame.zip). Would you please be so kind to check the model and let me know what is the mistake in it?
Thanking you.
Kind regards,
Nisar
Attachments
20211204_Bare Frame.zip
(141.03 KiB) Downloaded 10 times
Error.jpg
Error.jpg (255.56 KiB) Viewed 175 times

STKO Team
Posts: 893
Joined: Tue Oct 29, 2019 8:45 am

Re: Error During Analysis

Post by STKO Team » Mon Dec 06, 2021 9:11 am

Here's a working version of your model:
20211204_Bare Frame.zip
(144.47 KiB) Downloaded 9 times
Errors:
  • The fixities were applied to 2 vertices that were detached from the frame structure. So the structure was unstable. You did not need to create those 2 vertices. You should have simply applied the fixities to the end-vertices of the frame model.
  • A the end of the gravity analysis you need to reset the pseudo time to 0, otherwise the following displacement-controlled analysis, which uses the pseudo time as load multiplier, will start from a non-zero value.
  • The tolerance is too large. It accumulates errors at each step until the error is so large that the results are meaningless.
Suggestions:
  • In this model you don't need to use a Penalty constraint handler. The layout of your constraints is so simple that you can easily use the transformation method. (I changed it already)
  • You are modelling in N-mm, but the vertical loads are 195 N. Are you sure you didn't want to apply 196kN? (I did not change this, you can do it if necessary)

nisaralikhan
Posts: 7
Joined: Fri Sep 25, 2020 9:51 am

Re: Error During Analysis

Post by nisaralikhan » Mon Dec 06, 2021 9:43 am

Dear STKO Team,
Thank you for your prompt response and detailed explanations. Yes, I have done a mistake by putting 195 N instead of 195000. but when I put 195000 N it gives me again the same error.
I even tried to reduce the tolerance from the default value but all in vain.
Looking forward to hearing your response.
Kind regards,

STKO Team
Posts: 893
Joined: Tue Oct 29, 2019 8:45 am

Re: Error During Analysis

Post by STKO Team » Mon Dec 06, 2021 3:37 pm

Yes I forgot to mention that I already increased it using the cFactor = 1000 in the loadPattern.

Post Reply